PDA

View Full Version : MY 100-400L got stuck this moring cant pull on zoom anymore?



mikeisbeast
12-22-2005, 02:10 PM
so i went this morning to go take some surfing shots... all was gonig well thill the end. i tried pulling on the zoom and it was kinda tought mebe i didnt loosen the ring. so i pulled a lil harder and then after a few pulls got completely stuck at 40mm.. on the barrel theres some lil scratches runing long wise that werent there this moring.. lens works fine but i cant zoom.. also the adjustment ring(tightening/loosing) isnt perfectly spaced all the way through, theres a one side that its flush. help me guys this sucks big time i waited for a year to get this lens now idont know waht to do

T-Bird76
12-22-2005, 03:30 PM
Sounds like the bearings failed or some object is caught creating the friction in the push pull system. How old is the lens? If its within a year you're still covered under the warranty. Contact Canon and send it in ASAP. I wouldn't try fixing it on your own!

mikeisbeast
12-22-2005, 06:32 PM
it is less then a year old but problem is i bought it of some one so the warrenty isnt transferable so i got fork up for the repairs

PhilDernerJr
12-22-2005, 07:30 PM
I've heard of this happening to people, but no one that I know. Definitely a Canon service issue.

Sulman
12-29-2005, 07:21 AM
The very same thing happened to my friend Justin, when we were out shooting at EGHI in Summer. He'd mentioned the week before that the push-pull action was a little tighter than usual, and then he couldn't move it at all.

It was repaired by Canon under warranty. Hopefully if you have to pay it won't cost you too much.


Cheers

James